Manjaro Linux

Русское сообщество

linux manjaro проблема с обновлением

Проблемы и вопросы, касающиеся обработки пакетов с помощью pacman, kalu или pamac

linux manjaro проблема с обновлением

Сообщение Lx_b » 17 мар 2015, 18:12

Пользуюсь Linux впервые, около недели. До этого только щупал несколько распространённых дистрибутивов на ubs live.

Во время обновлении системных пакетов, процесс виснет при попытке удалить lxseasson. Написано он опционально нужен pacman, а двумя строками ниже предлагают его удалить. Pacman на запросы не отвечает.

После перезагрузки, при попытке продолжить обновление или при попытке установить пакеты локализации, пишет «ошибка авторизации»

В данный момент система установлена с нуля по новой.

При обновлении или при установке приложений, а также при просмотре видео в интернет, при любой продолжительной нагрузке, возникает проблема с wifi. Приходится щёлкать по подключенной сети, сеть переподключается и какое то время работает, а затем вновь пропадает.

Система:
Dell studio 17

Distro Vendor: Manjaro
Distro Release: 0.9.0-pre3
Desktop environment: XFCE4
Window manager: Xfwm4
Window manager Theme: Menda
GTK+ 2 Theme: Menda
GTK+ 3 Theme: Not Found
GTK Icons: Menda-Circle
GTK Font: Cantarell 10
***
Net-tools: 2.10-alpha
Arch: x86_64
Binutils 2.25.0
GCC Version: 4.9.2
Linux C Library: 2.21
GNU Make Version: 4.1
Dynamic linker (ldd): 2.21
***
Release: 3.14.35-1-MANJARO
***
wifi модуль - Intel Corporation WiFi Link 5100
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

Re: linux manjaro проблема с обновлением

Сообщение dimonmmk » 17 мар 2015, 20:04

Lx_b писал(а):Distro Release: 0.9.0-pre3
.........
Release: 3.14.35-1-MANJARO
Напрасно вы поставили 0.9.0-pre3. Сейчас стабильная версия 0.8.12, в своё время она самостоятельно обновится. Нольвосьмая станет нольдевятой, а потом и до первой доживем. Это же rolling-release model, здесь нету смысла гоняться за свежайшими сборками, тем более пре-релизами. Пре-релиз здесь- это бета беты, так чего ж Вы хотели?

Итак, ставьте 0.8.12, и обновите ядро. У Вас старое, 3.14.35-1-MANJARO, оно уже нормально не поддерживается, ставьте 3.18 или хотя бы 3.16.
Потом уже обновляйтесь.
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: linux manjaro проблема с обновлением

Сообщение Lx_b » 17 мар 2015, 20:45

dimonmmk писал(а):Напрасно вы поставили 0.9.0-pre3. Сейчас стабильная версия 0.8.12,
***
старое, 3.14.35-1-MANJARO, оно уже нормально не поддерживается, ставьте 3.18 или хотя бы 3.16.

Спасибо за ответ!
Вы меня огорошили! Я знаю про то, что существуют "тестируемые" новые релизы и старался скачать стабильную версию.
Собственно, если бы вы не написали, я так и не знал бы, что у меня не стабильная версия. :shock:
Дело в том, что я выбрал dounload xfce, нажав на ссылку я попал сюда - http://sourceforge.net/projects/manjaro ... .8.12-rc1/ Как теперь вижу, в тестовую ветку.
Спасибо, что наставили на путь истинный. :oops: :)

Вы пишите у меня старое ядро. Да я откатился на LTS версию, думал это поможет. К слову в окне ядра, у меня 3.16 отмечено как рекомендуемое, но стояло 3.19.

Из чего следует исходить при выборе ядра?
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

Re: linux manjaro проблема с обновлением

Сообщение dimonmmk » 17 мар 2015, 21:29

Lx_b писал(а):Из чего следует исходить при выборе ядра?

Надежнее всего поставить "рекомендуемое" ядро, но если хочется- можно поставить несколько ядер поновее, попробовать все, выбрать самое подходящее, остальные удалить. Самое свежее ставить не стоит, если конечно не окажется так что именно оно будет лучше всего работать с Вашим железом.
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: linux manjaro проблема с обновлением

Сообщение Lx_b » 18 мар 2015, 03:14

dimonmmk писал(а):Итак, ставьте 0.8.12

Поставил 0.8.12, ядро автоматически встало "рекомендуемое" 3.16.
К сожалению это не помогло. Система предложила мне обновить 1 пакет majaro_sistem (как то так). В какой то момент обновление застряло. Пришлось перезагрузиться. Теперь при попытке обновить, пишет - "ошибка авторизации". [smilie=dash2.gif]
Пакеты локализации по прежнему не встают, пишет нужно обновить систему.

Сильно подозреваю wifi модуль. При нагрузке, как я писал выше, соединение обрывается. В случае с обновлением системы, переподключение к wifi проблему не решает, даже временно. При установке приложений переподключение возвращает pacman к активности, если разумеется в это время шла загрузка, а не установка.
Последний раз редактировалось Lx_b 18 мар 2015, 03:23, всего редактировалось 1 раз.
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

Re: linux manjaro проблема с обновлением

Сообщение dimonmmk » 18 мар 2015, 03:35

Lx_b писал(а):Система предложила мне обновить 1 пакет majaro_sistem (как то так). В какой то момент обновление застряло. Пришлось перезагрузиться. Теперь при попытке обновить, пишет - "ошибка авторизации".

Попробуйте обновится в консольном режиме.
Проверьте, есть ли в файле /etc/pacman.conf строки:
Код: Выделить всё
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system
если нет, добавьте.
Перед первым обновлением запустите в терминале
Код: Выделить всё
sudo pacman-mirrors -g

Пусть отработает до конца, потом в том же терминале
Код: Выделить всё
sudo pacman -Syyu
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: linux manjaro проблема с обновлением

Сообщение Lx_b » 18 мар 2015, 16:38

dimonmmk писал(а):Попробуйте обновится в консольном режиме.

Спасибо, большое!
Не знаю, что в конечном итоге привело к удачному результату. Установить обновления удалось! :Yahoo!:

Процесс был таким:
Установил manjaro с нуля. /boot на отдельный первичный раздел 100мб(/ и /home на свои разделы логически разделы, как и swap). Процесс установки шёл в английской локализации. Сама установка при помощи "консоли" - стабильного инсталятора, сейчас не вспомню название. Их там всего два.

После установки, manjaro на английском. Локализацию пока не менял. WiFi по прежнему виснет.
Проверил запись в файле и использовал написанные вами команды. Лист зеркал обновился. При обновлении пакета manjaro-sistem процесс вновь застрял, но на другом месте. Без особой надежды, перезагрузил ОС и вновь использовал команды. В этот раз обновлений было 334 шт, их кол-во увеличилось в процессе обновления пакета manjaro-sistem. В результате этого обновления всё прошло удачно, лишь wifi подвисал и требовал переподключения.
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

Re: linux manjaro проблема с обновлением

Сообщение dimonmmk » 19 мар 2015, 01:10

Lx_b писал(а):Установить обновления удалось!

Хорошо. Я сегодня делал то же самое, только ставил и обновлял не консольными а графическими инструментами. Всё установилось и обновилось. Локализация, языковые пакеты, 3.18'е ядро, ппроприетарные драйвера- все прошло без проблем...
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: linux manjaro проблема с обновлением

Сообщение dimarik » 19 мар 2015, 15:36

Все проблемы такого рода решились сами собой когда поставил pre4 xfce и это же arch сразу ставить надо последнее , а не обновления по 300 шт накатывать. Хотя сам 3 раза переставил пока дошло что к чему.
Аватара пользователя
dimarik
 
Сообщения: 7
Зарегистрирован: 18 мар 2015, 11:14
Благодарил (а): 0 раз.
Поблагодарили: 3 раз.

Re: linux manjaro проблема с обновлением

Сообщение dimonmmk » 19 мар 2015, 17:02

dimarik писал(а):поставил pre4 xfce и это же arch сразу ставить надо последнее

:D Через месяц-другой, словив кернелпаник, виноватых будете искать в зеркале. :D
Ставить надо не последнее, и тем более не тестовый пререлиз, а последнее из стабильной ветки.

Добавлено спустя 2 часа 44 минуты 10 секунд:
Lx_b писал(а):ри обновлении пакета manjaro-sistem процесс вновь застрял, но на другом месте. Без особой надежды, перезагрузил ОС и вновь использовал команды. В этот раз обновлений было 334 шт, их кол-во увеличилось в процессе обновления пакета manjaro-sistem. В результате этого обновления всё прошло удачно

Сейчас ставлю Манжаро на другую машину, с новым (прошлогоднего выпуска) железом. Ранее ставил на относительно старое железо- все шло прекрасно. Сейчас, не новой машине, все происходит точно так же как Вы описали- при первом запуске фриз на проверке ключей, при втором- на проверке конфликтов пакетов. Pamac при этом наглухо стопорится, приходится килять процесс. А pacman- работает. :unknown:
Странный баг. Мелочь, конечно... Но странный.
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.


Вернуться в Управление пакетами



Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

cron