Manjaro Linux

Русское сообщество

[Решено]WiFi при постоянной нагрузке теряет подключение.

Проблемы и вопросы, касающиеся ядра и аппаратной поддержки.

[Решено]WiFi при постоянной нагрузке теряет подключение.

Сообщение Lx_b » 20 мар 2015, 18:15

Здравствуйте.

У меня Intel Corporation WiFi Link 5100 (vendor 0x8086 device 0x4232) wlp8s0(не знаю, что из этих данных понадобиться).

Если я пользуюсь браузером и просто просматриваю странички, то всё в порядке. Если же включить онлайн видео или радио, либо запустить торрент или иной вариант загрузки большого файла на ПК, wifi виснет. Помогает только переподключение к wifi сети. Порой приходиться делать это каждые 5-10 секунд. Так было при загрузке торрента. Последние % загрузки шли всё хуже и хуже. Когда осталось 10с до окончания, wifi обрывался раз 10, пока не докачалось.

В ubuntu studio к примеру или windows этих проблем в помине нет.

Очевидно дело в драйвере, подскажите какие действия следует предпринять для решения проблемы?
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение dimonmmk » 20 мар 2015, 20:23

Вывод двух команд- inxi -v2 & inxi -Nx покажите, plz.
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение Lx_b » 20 мар 2015, 21:08

dimonmmk, спасибо.
inxi -v2
System: Host: alx-home Kernel: 3.16.7.8-1-MANJARO x86_64 (64 bit)
Desktop: Xfce 4.12.0-MANJARO Distro: ManjaroLinux 0.8.12 Ascella
Machine: Mobo: Dell model: N/A v: A01 Bios: Dell v: A01 date: 07/16/2009
CPU: Dual core Intel Core2 Duo T6600 (-MCP-) speed/max: 1200/2200 MHz
Graphics: Card: Intel Mobile 4 Series Integrated Graphics Controller
Display Server: X.Org 1.17.1 driver: intel
Resolution: 1600x900@60.08hz
GLX Renderer: Mesa DRI Mobile Intel GM45 Express
GLX Version: 2.1 Mesa 10.4.6
Network: Card-1: Intel WiFi Link 5100 driver: iwlwifi
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169
Drives: HDD Total Size: 500.1GB (77.7% used) ID-1: model: ST9500420AS
Info: Processes: 145 Uptime: 5 min Memory: 768.5/3918.9MB
Client: Shell (bash) inxi: 2.2.19

inxi -Nx
Network: Card-1: Intel WiFi Link 5100
driver: iwlwifi v: in-tree: bus-ID: 08:00.0
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 20:00.0
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение dimonmmk » 20 мар 2015, 21:34

Для начала попробуйте переустановить пакет linux-firmware.

Добавлено спустя 3 минуты 31 секунду:
и покажите вывод dmesg | grep iwlwifi
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение Lx_b » 20 мар 2015, 22:55

dimonmmk писал(а):Для начала попробуйте переустановить пакет linux-firmware.
и покажите вывод dmesg | grep iwlwifi

dimonmmk, спасибо.
Переустановка пакета помогла, сперва. Затем всё стало как и раньше. Плюс слетела локализация и востановить её через графический интерфейс не удаётся.
Поначалу радио играло стабильно, изредка коротковременно подгружая буфер. Удалось через браузер скачать дистрибутив manjaro. Однако с прошествием времени,стало как раньше.

dmesg | grep iwlwifi
[ 7.638823] iwlwifi 0000:08:00.0: can't disable ASPM; OS doesn't have ASPM control
[ 7.638966] iwlwifi 0000:08:00.0: irq 47 for MSI/MSI-X
[ 7.706757] iwlwifi 0000:08:00.0: loaded firmware version 8.83.5.1 build 33692 op_mode iwldvm
[ 8.265376] iwlwifi 0000:08:00.0: CONFIG_IWLWIFI_DEBUG disabled
[ 8.265382] iwlwifi 0000:08:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[ 8.265384] iwlwifi 0000:08:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[ 8.265387] iwlwifi 0000:08:00.0: Detected Intel(R) WiFi Link 5100 AGN, REV=0x54
[ 8.265495] iwlwifi 0000:08:00.0: L1 Enabled - LTR Disabled
[ 12.257711] iwlwifi 0000:08:00.0: L1 Enabled - LTR Disabled
[ 12.260718] iwlwifi 0000:08:00.0: Radio type=0x1-0x2-0x0
[ 12.358724] iwlwifi 0000:08:00.0: L1 Enabled - LTR Disabled
[ 12.361720] iwlwifi 0000:08:00.0: Radio type=0x1-0x2-0x0


Добавлено спустя 39 минут 28 секунд:
Для переустановки пакета использовал инф. отсюда, команду sudo pacman -Sy linux-firmware. Верно? Как восстановить русскую локализацию? Пробовал этой же командой установить transmission, не получилось.
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение dimonmmk » 20 мар 2015, 23:36

Lx_b, на iwlwifi много нареканий. Точно сказать, почему он глючит- сложно, особенно когда он то работает, то нет... "плавающие" глюки- самые поганые...
Знаете что, давайте попробуем вообще отказаться от линуксового драйвера и установить виндовый. Понадобятся драйвера для ХР, и утилита ndiswrapper (она уже установлена).
Инструкции здесь http://forum.ubuntu.ru/index.php?topic=57020.0
Там мануал для убунту и другого драйвера, но Вы делайте по аналогии.

Добавлено спустя 13 минут 58 секунд:
Lx_b писал(а):Для переустановки пакета использовал инф. отсюда, команду sudo pacman -Sy linux-firmware. Верно? Как восстановить русскую локализацию? Пробовал этой же командой установить transmission, не получилось.

$#@!!!! Что ж Вы сделали-то?!!! Нельзя так! Вы ж базу испортили... Срочно sudo pacman -Syyuu , может, поможет...
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение Lx_b » 21 мар 2015, 01:16

dimonmmk писал(а):$#@!!!! Что ж Вы сделали-то?!!! Нельзя так! Вы ж базу испортили... Срочно sudo pacman -Syyuu , может, поможет...

переустановлю manjarо в шестой или восьмой раз за неделю... :%) [smilie=dash2.gif] :D
Только вчера раза 4 или больше переустанавливал, пока всё встало правильно.
Зашёл в Live с проприетарными драйверами с флешкой в спаренном разъёме, eSata+usb. Manjaro увидел флешку как sda, а хард как sdb. Как итог после установки не рабочий GRUB, переустановил. В другой раз не мог зайти в Иксы, пароль не принимал, думаю из-за криво вставшей локализации. В следующий раз ещё какой то косяк... [smilie=dash2.gif] Честно признаюсь, ушёл бы на ubuntu studio, кабы там у меня не вылетал Kdenlive и были некоторые утилиты и ПО, которые тут есть, а там из исходников ставить надо.


а как нужно было, какой командой? :oops: :unknown:
Как вы тут написали? -
dimonmmk писал(а):Код: Выделить всё
sudo pacman -Syyu && sudo pacman -Rs kdenlive && sudo pacman -S kdenlive

вы написали "sudo pacman -Syyuu". Мне так же писать или как в статье по вашей ссылке "sudo pacman -Syu"?

Добавлено спустя 4 минуты 22 секунды:
Как узнать помогла команда sudo pacman -Syyuu или нет, чем проверить?

Добавлено спустя 29 минут 36 секунд:
sudo pacman -Syyuu
Packages (45) blender-16:2.73a-4 btrfs-progs-3.19-1 ecryptfs-utils-106-1
ffmpeg-1:2.6.1-1 gambas3-gb-desktop-3.6.2-6
gambas3-gb-desktop-x11-3.6.2-6 gambas3-gb-form-3.6.2-6
gambas3-gb-image-3.6.2-6 gambas3-gb-qt4-3.6.2-6
gambas3-runtime-3.6.2-6 gptfdisk-1.0.0-1 gsfonts-20150122-1
kitemmodels-5.8.0-1 lib32-curl-7.41.0-1 lib32-libtasn1-4.3-1
lib32-libx11-1.6.3-1 lib32-llvm-libs-3.6.0-1
lib32-mesa-10.5.1-1 lib32-openssl-1.0.2.a-1 libssh-0.6.4-1
libtasn1-4.3-1 libvdpau-1.1-1 libxfce4ui-4.12.1-1
libxfont-1.5.1-1 llvm-3.6.0-3 llvm-libs-3.6.0-3 mesa-10.5.1-2
openimageio-1.4.16-2 openshadinglanguage-1.5.12-4
openssl-1.0.2.a-1 opera-28.0.1750.48-1 pamac-2.2-4
patch-2.7.5-1 perl-gdgraph-1.49-1 perl-list-moreutils-0.408-1
perl-test-fatal-0.014-1 qpdfview-0.4.14-2
system-config-printer-1.5.6-1 tcl-8.6.4-1 tcpdump-4.7.3-1
usb_modeswitch-2.2.1-1 xfce4-dict-0.7.1-1
xfce4-session-4.12.1-1.1 xfdesktop-4.12.0-1.5 xfwm4-4.12.2-1

Total Download Size: 153.15 MiB
Total Installed Size: 646.15 MiB
Net Upgrade Size: 24.33 MiB
Прошло успешно, без зависаний и ошибок.
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение dimonmmk » 21 мар 2015, 13:10

Lx_b писал(а):переустановлю manjarо в шестой или восьмой раз за неделю...

Редко кому удается сразу правильно поставить любой линукс и начать им спокойно пользоваться- все равно через какое-то время (от минут до дней) его случайно ломают, просто по неопытности. По неопытности же и починить не выходит, потому- реинсталл. :( Убунта не спасает, там все то же самое. Так что 8 раз- не предел, это нормально. :)

ЗЫ: вВера у меня тоже были проблемы с обновлением свежеустановленой манжаро. Да и не только у меня. Видимо, что-то с синхронизацией зеркал репов случилось, вышло свежее stable-обновление, но пакеты почему-то прилетали старые, а mirrorlist вообще пришёл битый. :( Ничего, сегодня все исправилось. Обновил и боевой десктоп, и ноут, и ту клиентскую машину, которая отказывалась обновляться вчера вечером.
ЗЗЫ: А ноутбук мой, на котором я как поставил когда-то манжаро-опенбокс еще 0.8.10 версии и с тех пор обновлял раз в квартал - обновился без всяких вопросов... Думаю, частые в последнее время обновления и их глюки связаны с переходом в версии 0.8.12_4 на XFCE 4.12.

Добавлено спустя 8 минут 11 секунд:
Lx_b писал(а):а как нужно было, какой командой?

Да просто pacman -S <имя пакета>

Добавлено спустя 8 минут 57 секунд:
Lx_b писал(а):Как вы тут написали? -
dimonmmk писал(а):
sudo pacman -Syyu && sudo pacman -Rs kdenlive && sudo pacman -S kdenlive

Это три команды, выполняемые одна за другой.
sudo pacman -Syyu - глобальное обновление системы, с принудительным скачиванием (второй y в опциях) всех баз (core, extra, community...)
sudo pacman -Rs <пакет> - удаление пакета с зависимостями.
sudo pacman -S <пакет> - установка пакета.
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение dimonmmk » 22 мар 2015, 16:34

Попробуйте ядро версии 3.17
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: WiFi при постоянной нагрузке теряет подключение.

Сообщение Lx_b » 22 мар 2015, 17:20

dimonmmk писал(а):Попробуйте ядро версии 3.17

Я изначально ставил, как потом выяснилось нестабильную ветку, manjaro 0.9 и ядро 3.18. Там у меня была такая же проблема. Попробую, спасибо.
Аватара пользователя
Lx_b
 
Автор темы
Сообщения: 59
Зарегистрирован: 17 мар 2015, 17:35
Благодарил (а): 23 раз.
Поблагодарили: 4 раз.

След.

Вернуться в Ядро & Оборудование



Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron