Manjaro Linux

Русское сообщество

[РЕШЕНО] Нет установки после разметки дисков

[РЕШЕНО] Нет установки после разметки дисков

Сообщение bespyatkin » 04 июн 2015, 21:50

Граждане! Второй день бьюсь и никак. Наверняка что-то простое. Ну вобщем как и положено шаг за шагом до разметки дисков. Устанавливаю на английском. Создаю раздел 159 Гиг под Манджару, точку монтирования, форматировать. Выделяю и... кнопка "Вперед" (Forward) не активна. Ставил до этого на нетбук 8.12 но там на весь диск без проблем и на другом компе тоже. А вот тут. Посоветуйте где копать? Прилагаю скрин.Изображение
Аватара пользователя
bespyatkin
 
Автор темы
Сообщения: 2
Зарегистрирован: 04 июн 2015, 21:30
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: Нет установки после разметки дисков

Сообщение Lem » 04 июн 2015, 22:32

bespyatkin
И не будет, тк диск разбит не так как хочет установщик (вам красная точка говорит чего не хватает)
Проблема же, или отличие случая тут от нетбука, в том что на нетбуке диск 100% не с GPT-разметкой, а с MBR.

Так что создавайте еще 1 раздел в 300-500 метров и назначайте точкой монтирования /boot/efi. Вот тогда дадут продолжить
Последний раз редактировалось Lem 04 июн 2015, 22:33, всего редактировалось 1 раз.
Аватара пользователя
Lem
 
Сообщения: 3
Зарегистрирован: 04 июн 2015, 22:27
Благодарил (а): 0 раз.
Поблагодарили: 2 раз.

Re: Нет установки после разметки дисков

Сообщение bespyatkin » 04 июн 2015, 23:31

Спасибо. Будем продолжать...
Аватара пользователя
bespyatkin
 
Автор темы
Сообщения: 2
Зарегистрирован: 04 июн 2015, 21:30
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: [РЕШЕНО] Нет установки после разметки дисков

Сообщение pellagin » 21 июл 2015, 08:08

В линуксе новичек, хотел бы установить Manjaro. Но смущает необходимость создания раздела /boot/efi

На ноутбуке винда и два линукса. Где расположить вышеуказанный раздел, чтобы загружались все ОС?

Вы, так понимаю, проблему решили, и как теперь выглядит таблица разделов? И, если я правильно понял, раздел для /boot/efi должен быть в формате fat 32?
Аватара пользователя
pellagin
 
Сообщения: 22
Зарегистрирован: 21 июл 2015, 07:34
Благодарил (а): 5 раз.
Поблагодарили: 0 раз.

Re: [РЕШЕНО] Нет установки после разметки дисков

Сообщение zaskock » 21 июл 2015, 16:45

pellagin
Все зависит от того как у вас установлены Windows и Linux, если таблица разделов MBR, то и Manjaro надо устанавливать так же, для того чтобы грузились все установленные системы и не пришлось бы потом преобразовывать таблицы разделов. Посмотреть можно командой
Код: Выделить всё
sudo fdisk -l или parted -l
. Если же Windows и Linux устанавливались в UEFI , то и Manjaro надо ставить в этом режиме. Собственно раздел boot/efi в этом случае уже существует и при установке Manjaro загрузчик Windows (Windows Boot Manager) будет просто отодвинут GRUB-ом на второе место в очереди загрузки.
Аватара пользователя
zaskock
 
Сообщения: 83
Зарегистрирован: 11 июн 2015, 14:50
Благодарил (а): 2 раз.
Поблагодарили: 9 раз.

Re: [РЕШЕНО] Нет установки после разметки дисков

Сообщение pellagin » 22 июл 2015, 02:00

Спасибо за отклик
Таблица разделов MBR,

sda1 - Windows boot
sda2 - расширенный
sda5 - swap
sda6 - Lubuntu
sda7 - homeLubuntu
sda8 - Zorin
sda9 - homeZorin

загрузчик — GRUB 2

C gparted управлюсь, перекроить диск и выделить место не проблема, возвращаюсь к своему вопросу: Где должен находиться раздел для /boot/efi?
Аватара пользователя
pellagin
 
Сообщения: 22
Зарегистрирован: 21 июл 2015, 07:34
Благодарил (а): 5 раз.
Поблагодарили: 0 раз.

Re: [РЕШЕНО] Нет установки после разметки дисков

Сообщение dimonmmk » 22 июл 2015, 02:47

pellagin писал(а):смущает необходимость создания раздела /boot/efi

pellagin писал(а):Таблица разделов MBR, ...
загрузчик — GRUB 2
Где должен находиться раздел для /boot/efi?

В вашем случае создавать раздел efi не нужно. Не смущайтесь, спокойно ставьте Манжаро версии 8.13 .
Судя по скрину, у топикстартера проблемы с установкой тестовой ветки, к Вам это отношения не имеет.
Аватара пользователя
dimonmmk
 
Сообщения: 604
Зарегистрирован: 10 июл 2014, 19:08
Откуда: 57° 3'51.28" 36° 1'43.38"
Благодарил (а): 14 раз.
Поблагодарили: 134 раз.

Re: [РЕШЕНО] Нет установки после разметки дисков

Сообщение pellagin » 22 июл 2015, 11:58

Что-то ничего у меня не вышло. Скачал манжару, записал на мультизагрузочную флешку, но оттуда загрузить не получилось. Записал на диск - здесь загрузка пошла, но потом ос не запустилась, да и вообще ноут не запускался. Записал еще на одну флешку с помощью unetbootin - здесь манжара повела себя вообще странно - интернет-соединение в лайв режиме создавалось, но выйти в нет не получалось по причине поломки апплета ( а с диска и мультибута в лайв-режиме все работало на отлично). Решил все же поставить на ноубук, после перезагрузки груб совсем слетел.
Манжару снес и научился восстанавливать GRUB2 :oops:
Да, хеш проверил, там все правильно. Диск писал на k3b.
Конечно, и раньше замечал, что не все дистры грузятся с флешки, а диск был рв-шный, дважды переписанный, какой был под рукой. Может в этом все дело, но вот чтобы фажок boot какой-либо линукс утягивал с первого раздела на себя - это увидел впервые. А так да, создавать EFI раздел не требовалось.
И еще: пробовал устанавливать и с нон-фри драйверами, и без оных - результат один.
Интересно, только у меня такие проблемы? Может кто чего посоветует.
Аватара пользователя
pellagin
 
Сообщения: 22
Зарегистрирован: 21 июл 2015, 07:34
Благодарил (а): 5 раз.
Поблагодарили: 0 раз.

Re: [РЕШЕНО] Нет установки после разметки дисков

Сообщение vacka » 22 июл 2015, 12:41

pellagin писал(а):Скачал манжару, записал на мультизагрузочную флешку, но оттуда загрузить не получилось.

Аналогичная ситуация была и именно с manjaro-xfce-0.8.13 (с 0.8.12 было всё нормально), с мультизагрузочной флешки не получалось загрузиться. Пришлось записывать другую флешку с помощью dd, проблема с загрузкой и установкой решилась.
vacka
 
Сообщения: 64
Зарегистрирован: 21 апр 2015, 19:03
Благодарил (а): 3 раз.
Поблагодарили: 22 раз.

Re: [РЕШЕНО] Нет установки после разметки дисков

Сообщение pellagin » 23 июл 2015, 03:49

Создал флешку с помощью dd, записал на нее образ manjaro-xfce-0.8.13.1-i686.iso, установил на ноут.
При запуске появляется сообщение об отсутствии наличия файловой системы с предложением установить ос (HP). В лайв режиме восстанавливаю grub, однако провести update-grub не удалось . Загружаю ноут, в меню GRUB 2 появляются пункты с Manjaro, но при их выборе - kernel panic.Обновляю grub — без изменений. Другие ос загружаются, файловый менеджер видит Manjaro. Никак не пойму, в чем моя ошибка. Пробовал восстанавливать grub, смонтировав раздел с Manjaro — после команды grub-install /dev/sda появляется: невозможен каноничный путь /cw :( После чего делал так: grub-install --recheck /dev/sda и еще так: grub-install --recheck --no-floppy /dev/sda — ответ тот же.
Впрочем, благодарю всех за советы, немало интересного почерпнул в свих поисках решения проблемы.
Досадно однако, что саму проблему никак решить не могу.
Последний раз редактировалось pellagin 23 июл 2015, 04:26, всего редактировалось 3 раз(а).
Аватара пользователя
pellagin
 
Сообщения: 22
Зарегистрирован: 21 июл 2015, 07:34
Благодарил (а): 5 раз.
Поблагодарили: 0 раз.

След.

Вернуться в Вопросы, связанные с установкой



Кто сейчас на конференции

Сейчас этот форум просматривают: Google Adsense [Bot] и гости: 2

cron